Problem
Differences in engagement metrics, such as open and click rates, are observed between the Campaign Stats dashboard and the Campaign Analytics page in MoEngage.
Cause
The differences in engagement metrics, such as open and click rates, between Campaign Stats and Campaign Analytics occur due to differences in their analytical logic. While both features are part of the same platform, they present similar data in distinct ways to meet specific analysis requirements.
Solution
To understand and resolve this difference, review the following points:
- Query duration
- The campaign dashboard displays data for a specific time range, such as the past seven days.
- Events and metrics outside this time range are not included.
- Clicked campaign redirect
- When you click a campaign, the system redirects you to the Campaign Analytics page.
- This page shows the campaign's lifetime metrics, regardless of the time range.
- Data calculation
- Consolidated Campaign stats on the dashboard calculate metrics based only on events within the selected time range.
- Events that occurred outside of the specified time range are excluded.
- Events outside the selected time range
- A campaign could be initiated and include events outside the selected time range.
- This can result in discrepancies, such as a lower sent count but a higher opened or clicked count, which can increase the click-through rate (CTR) or conversion rate (CVR).
- Expected behavior
- This behavior is expected. The campaign dashboard focuses on recent activity for the specified time range, while the Campaign Analytics page provides a complete overview of the campaign's performance.
info |
Information The campaign analytics pages display a comprehensive view of the campaign's lifetime data, while the dashboard focuses on a more recent data set based on the selected time range. |