Why Do CTRs Go Over 100% of the Total Number of Impressions?

Problem

Some Push campaigns have Click-Through Rates (CTRs) over 100%, which appears incorrect and raises doubts about accuracy.

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Cause

The following are the reasons for high CTR:

  • When the SDK fails to track impressions for iOS, it leads to a count of zero, even though clicks are still recorded. This can inflate the overall CTR if Android counts are coming from inbox.
    For more information, refer to Why Are Push Campaign Impressions Not Tracked on iOS Devices?
  • When sticky push notifications allow users to click multiple times, specifically for small targeted user bases, leading to a higher number of clicks than impressions.
    For more information, refer to the Advanced tab in Push Templates.
  • When app inbox is enabled allowing end users to click on old notifications from the app's inbox, resulting in multiple clicks being registered for a single user.
    For more information, refer to Notification Center for Android and iOS Notification Center for iOS.
  • In some rare instances, integration issues with self-handled push notifications can occasionally cause duplicate click callbacks to be sent, leading to an increase in the CTR.
    For more information, refer to Push Handled by Application for Android and Push Display Handled by Application for iOS.

Explanation

  • To calculate CTR, use the formula: CTR = (Total Clicks / Total Impressions) * 100.
  • MoEngage tracks iOS campaign impressions differently based on the Show iOS Impressions Toggle.
  • When you turn the toggle off, sent messages are counted as impressions. 
  • When you turn the toggle on, the actual impression count is based on the Notification Received iOS event.

Example

For instance, if you have 2000 impressions on your campaign, the reported CTR might be higher than 2,000.

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