Why Is the Mobile Webpage Refreshed Repeatedly for OSM Users?

Problem

When the On-site Messaging (OSM) campaign starts, the mobile webpage is refreshed continuously. However, if the campaign is stopped or paused, the refresh stops.

Cause

The issue arises due to a mismatch between the campaign's expiry time and the countdown timer, causing the mobile webpage to be refreshed repeatedly.

Solution

  1. Move the redirection URL from a <div> to a button to prevent immediate redirection when the OSM loads.
  2. Ensure that the campaign expiry time and the countdown timer expiry time are exactly the same.
    Countdown timer expiry time:
    5th july mobile 2.png
    Campaign expiry time:
    Untitled design (12).png

Was this article helpful?
0 out of 0 found this helpful

How can we improve this article?