ユーザーはパーソナライズの失敗により削除されます

問題

メールキャンペーンでターゲットにされたすべてのユーザーは、パーソナライゼーションの失敗により削除されました。

mceclip0.png

原因

パーソナライズはカスタム属性「First Name」に基づいていたため、このキャンペーンのパーソナライズは失敗しました。これは、ターゲットセグメント内のユーザーのいずれにもこの属性が存在しなかったため、MoEngageが追跡する属性「First Name」を参照していたからです。

パーソナライゼーションコード: {{UserAttribute['First Name']|default('MOE_NOT_SEND')}}

カスタム属性「First Name」とMoEngageトラッキング属性「First Name」の両方の属性の読みやすい名前が同じであるため、パーソナライゼーションはMoEngageトラッキング属性を参照し、カスタム属性を参照しません。

解決策

MoEngageで追跡される属性と同じ名前のカスタム属性を追跡することは推奨されません。これらは予約済みのキーワードだからです。ユーザープロファイルでこのデータを追跡することは可能ですが、これらの属性に基づいてパーソナライズを行う際に問題が発生するでしょう。

MoEngageで追跡される属性のリスト:

1) 名前
2) 名
3) 姓
4) 誕生日
5) 性別
6) 場所
7) 携帯番号 (標準)
8) メール (標準)
9) ID
10)広告識別子

この記事は役に立ちましたか?
1人中0人がこの記事が役に立ったと言っています

How can we improve this article?