なぜテストインアプリがデバイス上でレンダリングに失敗するのか (In-App V2)?

問題

アプリ内キャンペーンのテストは、アプリ内の見た目と反応を確認する最後のステップで失敗します。

原因

この問題は次のいずれかの理由で発生する可能性があります:

  • カスタムリダイレクション : アプリ内テストキャンペーンを送信すると、スプラッシュスクリーンまたは空のアクティビティが開き、その後、アプリ内メッセージが表示されるメインアクティビティ画面にリダイレクトされます。しかし、この問題のために、アプリ内メッセージを取得するためにサーバーに行われる呼び出しがドロップしてしまい、そのためユーザーはキャンペーンを見ることができません。
  • アクティビティ名が見つかりません : アプリ内メッセージをテストしているとき、バックエンドからランダムなアクティビティが選択されて画面に表示されますが、そこにアクティビティがない場合、MoEngageはアプリ内メッセージを表示しません。
  • キー-バリュー ペア : キャンペーン作成で見られるものとは異なります。バックエンドから取得され、時にはアプリ内メッセージのテスト中に発生します。キー-バリュー ペアが欠落している場合、アプリ内メッセージは表示されません。
  • アクティビティインスタンスがnullです : これは、画面がない場合でも、MoEngageはアプリ内メッセージを表示できないことを意味します。

ソリューション

自分自身またはテストユーザーのグループをターゲットにしたテストキャンペーンを作成できます。

この記事は役に立ちましたか?
7人中1人がこの記事が役に立ったと言っています

How can we improve this article?